Chronicle 7.0 And macOS 10.9

Chronicle 7.0 for Mac now requires macOS 10.10 or higher in order to work properly. Unfortunately, we didn’t properly update this in the App Store when the initial 7.0 update was released. As a result, if you are running macOS 10.9, it was possible to update to version 7, which opened up as a blank window. If this happened to you, please take the following steps to downgrade to the latest version of Chronicle that is compatible with macOS 10.9:

  1. Delete your copy of Chronicle on your Mac by dragging it to the trash.
  2. Launch the Mac App Store, and go to the “Purchased” page.
  3. Find Chronicle on the list, and click the Install button. You will be prompted to install the latest compatible version, which is version 6.7.3.

Shopping Cart